Errors/Warnings/Bugs

Announcements, comments, ideas, feedback, and "How do I... ?" questions
User avatar
euler
Administrator
Posts: 3702
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thank you for pointing that out. It should now be fixed. I did a DB search and there don't seem to be any more instances of that relic.
Image
impudens simia et macrologus profundus fabulae
Yly
Posts: 1
Joined: Mon Aug 23, 2021 5:44 am

Re: Errors/Warnings/Bugs

Post by Yly »

This is a problem I regularly run into: I open a problem page and work on the problem for a while. If I take keep the page open sufficiently long, something goes stale on the webpage, so that when I try to input an answer I am simply returned to the archives page. If I then navigate back to the problem page and try to input the answer again, I am told that I cannot submit an answer within 30 seconds of a previous submission. This happens even if the answer I submit is correct.

This is quite irritating! If it helps to diagnose this problem, my web browser is the following:
Chromium, Version 89.0.4389.82 (Official Build) Built on Ubuntu , running on LinuxMint 18.2 (64-bit)
User avatar
euler
Administrator
Posts: 3702
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Hi, Yly.

I've tried twice now to reproduce, leaving the page open for a couple of hours then submitting an answer, and I am not experiencing the problem.

I've checked through the scripts and I cannot find a redirect directly to the archives page AFTER your last submission has been processed.
Are you seeing a message, like, "The confirmation code you entered was not valid"?
When you say you've been working on the problem for a while, what period of time are you referring to?
Image
impudens simia et macrologus profundus fabulae
User avatar
Artem-2004
Posts: 2
Joined: Sun Aug 29, 2021 11:36 am
Contact:

Re: Errors/Warnings/Bugs

Post by Artem-2004 »

Jochen_P wrote: Wed Aug 21, 2019 8:51 am Minor hickup at the moment..

seems that the profile pictures are currently not generated.

(like in https://projecteuler.net/profile/Jochen_P.png)
I have the same problem
How do I get a "profile image"? When you click on the link [link] https://projecteuler.net/profile/artexxx.png[/link], it does not appear.
Attachments
photo when clicking on the link https://projecteuler.net/profile/artexxx.png
photo when clicking on the link https://projecteuler.net/profile/artexxx.png
Desktop_210831_1243.jpg (14.84 KiB) Viewed 153 times
Image
User avatar
hk
Administrator
Posts: 11399
Joined: Sun Mar 26, 2006 10:34 am
Location: Haren, Netherlands

Re: Errors/Warnings/Bugs

Post by hk »

Currently your account is private. For private accounts no profile image is generated.
If you make your account Public a profile image is shown.
Image
SaxTenor
Posts: 4
Joined: Mon Sep 28, 2020 11:05 am

Re: Errors/Warnings/Bugs

Post by SaxTenor »

On the Progress / Awards tab, the link for the "Perfection" award does not work (https://projecteuler.net/award=27).

I manually tried many numbers other than 27 with no success. I guess the page no longer exists.
shs.10978
Posts: 5
Joined: Sun Mar 03, 2019 9:33 pm

Re: Errors/Warnings/Bugs

Post by shs.10978 »

In Problem 765's thread, two users posted the exact answer in code blocks. Both showed 267... which lost the first digit in the numerator; but if quoted, we can see the digit is there in the raw text (2267...).

The was previously observed in another thread (viewtopic.php?f=5&t=2720&p=58858#p58858) . Is there a more systemic fix?
User avatar
euler
Administrator
Posts: 3702
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

@SaxTenor: Having that award as a clickable link was an oversight. It is not longer clickable. Although you can earn the award, and anyone who does earn it should be very proud, we do not display which members have earned it. Although it is an incredible achievement and the vast majority have earned it through sheer hard work, the lure of appearing among those greats encouraged some members to earn it by less honest means.

@shs.10978: I've fixed the problem. I identified the issue from a curious line of code that I'd added. I know I must have put it in there to fix another previous issue, but cannot remember what that was precisely. I've not removed the line, but modified it to not interfere as it had been. We will need to keep a close eye on things as it might soon emerge why I had it there in the first place! :lol:
Image
impudens simia et macrologus profundus fabulae
Post Reply