Site Maintenance (Fri 29 Jan 21)

Announcements, comments, ideas, feedback, and "How do I... ?" questions
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Site Maintenance (Fri 29 Jan 21)

Post by euler »

Recently it has became apparent that Project Euler was suffering intermittent load issues. After closely monitoring performance during the busiest times it was determined that a complete overhaul of the way in which certain data is stored would be needed. This has required a significant change to most of the scripts and the way that data is stored in the database.

Today Project Euler was taken offline to upload those changes. It is hoped that this provides better stability during busy periods for many years into the future. But as always, with such extensive changes, it is possible that some unwanted critters may have slipped past the bugman. If you notice any unusual behaviour or bugs, please report it here.
Image
impudens simia et macrologus profundus fabulae
TwoFx
Posts: 2
Joined: Fri Jan 29, 2021 5:12 pm

Re: Site Maintenance (Fri 29 Jan 21)

Post by TwoFx »

It appears that submitting solutions does not work. I get the green checkmark together with the "Congratulations, the answer you gave to problem X is correct." message, but my profile isn't updated, I don't get access to the form, etc.
Image
philiplu
Posts: 46
Joined: Wed Aug 02, 2017 8:51 pm
Location: Redmond, WA, USA

Re: Site Maintenance (Fri 29 Jan 21)

Post by philiplu »

The Progress/Posts page is broken. Everything below the menu bar is missing, both on an iPad and Win10 (Google Chrome both places).

Image

Update I guess you're actively working in the area right now. The behavior just changed - looks like before, except now I see "SQLSTATE[42S22]: Column not found: 1054 Unknown column 'archive' in 'field list'" below that menu bar.

Update 2 And it's back. Thanks!
Last edited by philiplu on Fri Jan 29, 2021 5:26 pm, edited 1 time in total.
Image
Obergscheidle
Posts: 8
Joined: Fri Jul 15, 2016 7:24 pm

Re: Site Maintenance (Fri 29 Jan 21)

Post by Obergscheidle »

I was trying to look at solved problems in the archive, but I see a lot of unsolved ones.
Image
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

@philiplu: Could you check again to see if it is fixed?
Image
impudens simia et macrologus profundus fabulae
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

Obergscheidle wrote: Fri Jan 29, 2021 5:24 pm I was trying to look at solved problems in the archive, but I see a lot of unsolved ones.
Could you describe the problem? I looked up your username, but you must have changed it on the main website.
Image
impudens simia et macrologus profundus fabulae
philiplu
Posts: 46
Joined: Wed Aug 02, 2017 8:51 pm
Location: Redmond, WA, USA

Re: Site Maintenance (Fri 29 Jan 21)

Post by philiplu »

Progress/Posts now working.

Seeing problems with the Friends page. The hover-text over a login ID, telling me when the most recent solution was submitted, is off. I'm seeing a lot of "<name> last solved a problem within the past day" or "... #n days ago" with n within the past week, even for people who haven't solved anything in months. If I look at the same hover-text on, say, the Awards/Level list, the days since last solution seems correct, though that might be because it was cached a while ago, while it seems the Friends page isn't cached.

Also, if I click through the name on the Friends page to open their Progress/Problems page, the display is truncated. All I see is everything to the "Problems Solved" sub-head, but everything after that is missing, the color-coded table of solved problems and the problem difficulty ratings table.

Update Click-through to a friend's Progress/Problems page is now working.
Last edited by philiplu on Fri Jan 29, 2021 5:51 pm, edited 1 time in total.
Image
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

TwoFx wrote: Fri Jan 29, 2021 5:14 pm It appears that submitting solutions does not work. I get the green checkmark together with the "Congratulations, the answer you gave to problem X is correct." message, but my profile isn't updated, I don't get access to the form, etc.
I think I've fixed that now. Could you verify?
Image
impudens simia et macrologus profundus fabulae
Obergscheidle
Posts: 8
Joined: Fri Jul 15, 2016 7:24 pm

Re: Site Maintenance (Fri 29 Jan 21)

Post by Obergscheidle »

euler wrote: Fri Jan 29, 2021 5:29 pm
Obergscheidle wrote: Fri Jan 29, 2021 5:24 pm I was trying to look at solved problems in the archive, but I see a lot of unsolved ones.
Could you describe the problem? I looked up your username, but you must have changed it on the main website.
My username on the main website is AndreasEisele. I see the problem when I select solved problems and then sort by difficulty or number of solvers. E.g. problems 696, 494 etc. should not be seen in the following list:
http://81.88.24.251/eulerbug/EulerBug.jpg
Image
TwoFx
Posts: 2
Joined: Fri Jan 29, 2021 5:12 pm

Re: Site Maintenance (Fri 29 Jan 21)

Post by TwoFx »

euler wrote: Fri Jan 29, 2021 5:39 pm I think I've fixed that now. Could you verify?
It works! Thanks a lot for all of the work you put into this site, it is very much appreciated.
Image
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

@TwoFx: Thanks for the update. And you're very welcome. 8-)

@AndreasEisele: That's helpful. Thank you. It should be fixed now. Also, would you like your username on this forum to be changed to match the main website? If you do, then please send me a private message.

@philiplu: I think I've managed to fix those two issues.
Image
impudens simia et macrologus profundus fabulae
JohnsSmyth
Posts: 4
Joined: Mon May 18, 2020 7:38 am

Re: Site Maintenance (Fri 29 Jan 21)

Post by JohnsSmyth »

When I view a solved problem, it shows me the time and date that I solved the previous problem, if I have also solved that one. Otherwise no time and date is displayed.

There also seems to be an issue with the fastest solvers list. Some users appear multiple times in most recent problems. The first 20 entries in problem 739 and 740 appear to be the same.
philiplu
Posts: 46
Joined: Wed Aug 02, 2017 8:51 pm
Location: Redmond, WA, USA

Re: Site Maintenance (Fri 29 Jan 21)

Post by philiplu »

euler wrote: Fri Jan 29, 2021 6:18 pm @philiplu: I think I've managed to fix those two issues.
Still seeing a bit of weirdness in the Friends page. The mouse-over hover-text used to show how long it had been since the user solved a problem, but now it's saying how long it's been since the user was active, which I assume means logged into the system and having issued a page-load somewhere. So now, for instance, the hover-text over my name says "philiplu is active right now" instead of "philiplu solved a problem in the past day" or whatever.

This is also happening in other pages where the same hover-text was available, like Statistics/Levels or Statistics/Locations.

Not sure if this was intentional or not, but the "last solved a problem" info is probably more interesting than "last active" to me.
Image
Tiny_Snow
Posts: 1
Joined: Sat Jan 30, 2021 6:28 am

Re: Site Maintenance (Fri 29 Jan 21)

Post by Tiny_Snow »

The Completion time on my problem page became the Completion Time on the previous problem, which is wrong on the Archives page, but normal on the Progress page.

Also, I can't download Overview.pdf right now, and clicking it takes me directly to the list of questions.

Hope all the above problems can be fixed.THANKS!
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

@JohnsSmyth & Tiny_Snow: Completion dates/times should now be fixed.
@JohnsSmyth: Not sure what happened with the fastest solvers tables for those two problems. I forced them to be re-cached and it not displays correctly. We'll have to keep an eye on that one.
@Tiny_Snow: Overviews should now load correctly.
@philiplu: Yes, it was intentional. I realise how disappointing that can be when all that is seen on the website is potentially one or two things removed or not done as it was before. It's to do with the way/type of data we keep. Previously there was a separate timestamp for the last solved problem, but that is no longer kept. It was one of the compromises made in an attempt to streamline the back-end processes. I am hoping that the all the work done will be worth it, in terms of making the whole platform more stable and improving overall performance.
Image
impudens simia et macrologus profundus fabulae
vrobyka
Posts: 6
Joined: Mon May 20, 2013 9:10 am

Re: Site Maintenance (Fri 29 Jan 21)

Post by vrobyka »

Hi! Maybe this is due to the changes: my score in the leader board seems to be incorrect. I have several top 50 placements in the 10 most recent problems which are not included in my score.
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

Could you be specific about the problem? I'm struggling to know what I'm looking for. I've just checked and your position for the most recent problem (#744) is 40. Is there another problem where you are not appearing?
Image
impudens simia et macrologus profundus fabulae
vrobyka
Posts: 6
Joined: Mon May 20, 2013 9:10 am

Re: Site Maintenance (Fri 29 Jan 21)

Post by vrobyka »

I'm 10th on problem 743 and 44th on problem 740. Neither are included in my score. But I guess this is a more general issue, also affecting others.
JohnsSmyth
Posts: 4
Joined: Mon May 18, 2020 7:38 am

Re: Site Maintenance (Fri 29 Jan 21)

Post by JohnsSmyth »

euler wrote: Sat Jan 30, 2021 9:26 am @JohnsSmyth: Not sure what happened with the fastest solvers tables for those two problems. I forced them to be re-cached and it not displays correctly. We'll have to keep an eye on that one.
The fastest solvers for problem 736, 737 and 738 are also incorrect - some users appear multiple times and 3 hours for 100th place in problem 738 seems too fast.
Update It has been fixed.
Last edited by JohnsSmyth on Sun Jan 31, 2021 12:39 am, edited 1 time in total.
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Site Maintenance (Fri 29 Jan 21)

Post by euler »

vrobyka wrote: Sat Jan 30, 2021 11:29 pm I'm 10th on problem 743 and 44th on problem 740. Neither are included in my score. But I guess this is a more general issue, also affecting others.
I'm really confused. I can see you in the fastest tables at position 10 for #743 and position 40 for #744. Is it not displaying for you?
Image
impudens simia et macrologus profundus fabulae
Post Reply