Errors/Warnings/Bugs

Announcements, comments, ideas, feedback, and "How do I... ?" questions
v6ph1
Posts: 122
Joined: Mon Aug 25, 2014 7:14 pm

Re: Errors/Warnings/Bugs

Post by v6ph1 »

Image

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thanks for reporting this. This forum was moved today and in that process it seems that the DNS records for the main site were affected. It may take a short time for the DNS to update, but everything should be sorted now. Hopefully this is the last issue we face and all sites (.net and .chat) should remain stable for quite some time to come.
Image
impudens simia et macrologus profundus fabulae

v6ph1
Posts: 122
Joined: Mon Aug 25, 2014 7:14 pm

Re: Errors/Warnings/Bugs

Post by v6ph1 »

Thanks - for me, it's working again. :D
Image

mdean
Posts: 165
Joined: Tue Aug 02, 2011 2:05 am

Re: Errors/Warnings/Bugs

Post by mdean »

This site's been down quite a bit lately it seems. Some sort of SQL error, not always the same each time.
Image

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thanks for reporting this. I do get emails when the site goes down and I notice it went down twice yesterday at around 02.50 (UK time) for 15 minutes and 20.20 for 15 minutes. I'll keep an eye on things.
Image
impudens simia et macrologus profundus fabulae

User avatar
FourLegsDriveCat
Posts: 21
Joined: Tue Sep 11, 2012 9:18 pm
Location: Ukraine

Re: Errors/Warnings/Bugs

Post by FourLegsDriveCat »

Problems are hard to read in Google Chrome (latest) on Android tablet (Samsung SM-T820), formulas are partially overlapped with text. Please see attached screenshot.
Edit: Zooming doesn't change anything. I attached second screenshot with latest problem (690).
Attachments
Screenshot_20191127-200307_Chrome.jpg
Screenshot_20191127-200307_Chrome.jpg (303.34 KiB) Viewed 3351 times
Screenshot_20191121-200046_Chrome.jpg
Screenshot_20191121-200046_Chrome.jpg (331.61 KiB) Viewed 3429 times

mdean
Posts: 165
Joined: Tue Aug 02, 2011 2:05 am

Re: Errors/Warnings/Bugs

Post by mdean »

I probably should have noted when this happened, but one of my last times attempting to access the forums, I instead got something on the bottom of the screen asking "What do you want to do with index.php?", giving me the option to open, save, or cancel.

And now when I try to pin or unpin a problem, I get the screen saying "The page you are looking for cannot be found or you broke something. Click above to restore normality." The problem does pin or unpin correctly.
Image

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thanks for reporting it.

They are both unrelated issues. The pinning/unpinning problem has now been fixed. The accessibility issue to this forum: Open or Save dialogue appearing, is still going on. I have been made aware of it twice in the past two days and I'm waiting for our hosts to get back on the issue.
Image
impudens simia et macrologus profundus fabulae

kailey
Posts: 3
Joined: Mon Mar 02, 2020 4:19 pm

Re: Errors/Warnings/Bugs

Post by kailey »

I was #47 to solve the 702 problem, but didn't appear in fastest, then I checked my account settings and found it unlisted, I have un-unlisted my account, but it is not appearing in fastest. I am able to access threads, is there a way to get my account listed in fastest?

Image

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

It looks like you were the 48th person to solve that problem and you're currently listed in the fastest solvers table:
https://projecteuler.net/fastest=702

The information that told you your position when you first solved the problem is independent of whether or not your account was listed or unlisted. But if your account was unlisted, then you would not have appeared in the table when you first solved the problem. Fortunately, a timestamp keeps an accurate record of when you solved the problem. However, when you relisted your account, you would not appear automatically. The good news is that the next time someone else solves a problem or the cache is updated, then the table is regenerated and you would appear at your rightful place.
Image
impudens simia et macrologus profundus fabulae

mdean
Posts: 165
Joined: Tue Aug 02, 2011 2:05 am

Re: Errors/Warnings/Bugs

Post by mdean »

I appear to be unable to delete private messages. I mark 2 of them, select "Delete marked" and click "Go". I get a message saying "The submitted form was invalid. Try submitting again."
Image

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thanks for reporting that. It seems to be a bug, and a known issue, with the latest version of phpBB. I've modified a few of scripts to fix it, but hopefully a proper fix comes on the next iteration. In the meantime, I tested it myself and it seems to be working again.
Image
impudens simia et macrologus profundus fabulae

khengari77
Posts: 2
Joined: Fri May 01, 2020 11:19 pm

Re: Errors/Warnings/Bugs

Post by khengari77 »

since I signed up in project Euler I'm facing this problem my answers aren't accepted
nor updating my account can you help me solve this.
02.05.2020_00.26.52_REC.png
02.05.2020_00.26.52_REC.png (15.38 KiB) Viewed 2308 times
02.05.2020_00.27.55_REC.png
02.05.2020_00.27.55_REC.png (6.61 KiB) Viewed 2308 times

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

You emailed me with exactly this issue. When I replied, I said that if you're seeing that error, then you're probably using a browser plug-in that is interfering with form submissions. I'm more than happy to help, but you'll need to give me some information. It would be good to know which browser/version you're using. I also suggest that you try turning off each one systematically to determine which one is causing the issue. If I were a betting man, I'd put money on a version of ad block that you're using.
Image
impudens simia et macrologus profundus fabulae

khengari77
Posts: 2
Joined: Fri May 01, 2020 11:19 pm

Re: Errors/Warnings/Bugs

Post by khengari77 »

You emailed me with exactly this issue. When I replied, I said that if you're seeing that error, then you're probably using a browser plug-in that is interfering with form submissions. I'm more than happy to help, but you'll need to give me some information. It would be good to know which browser/version you're using. I also suggest that you try turning off each one systematically to determine which one is causing the issue. If I were a betting man, I'd put money on a version of ad block that you're using.
I'm afraid that you've lost the bet I don't use ad blocking extensions. Anyway I've solved the problem it was the developer mode in chrome I had to turn it off and I'm sorry about the email I checked it 3 hrs ago and found nothing it seems that you've replied recently.

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Fortunately I'm not a betting man. But thank you very much for getting back. As I mentioned in the email, I've had reports about this issue in the past and in those cases we were able to identify it as a badly behaving plug-in. So when I've sent that suggestion to others, who reported the same problem, I often get a quick reply to confirm that it was the cause of their problem too. It's always useful to be able to provide a fix, but this is new information you're giving me for which I'm grateful. Do you have any idea why developer mode would cause this?
Image
impudens simia et macrologus profundus fabulae

user202729
Posts: 6
Joined: Tue Dec 29, 2015 2:58 pm

Re: Errors/Warnings/Bugs

Post by user202729 »

Minor bug: There's a gray box on this page https://projecteuler.net/about=forum_rules , which remains gray in the dark theme. That's too light.

For comparison, the disclaimer box in the /about page is much darker in the dark theme.

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Done. 8-)
Image
impudens simia et macrologus profundus fabulae

mdean
Posts: 165
Joined: Tue Aug 02, 2011 2:05 am

Re: Errors/Warnings/Bugs

Post by mdean »

Site's been down a lot today. Keeping this brief in case...
Image

User avatar
euler
Administrator
Posts: 3317
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Yes, it started yesterday about 6pm UK time and the site has been up and down numerous times. Our hosts are aware of it as it was an issue across their network shared hosting network (where this forum resides). Fortunately the main site is on its own VPS, so it has been unaffected. I'm hoping it is resolved now.
Image
impudens simia et macrologus profundus fabulae

Post Reply