Errors/Warnings/Bugs

Announcements, comments, ideas, feedback, and "How do I... ?" questions
LilStalker
Posts: 54
Joined: Thu Nov 03, 2016 4:32 pm

Re: Errors/Warnings/Bugs

Post by LilStalker » Sat Dec 08, 2018 5:48 pm

It says that problem 644 was solved by 60 members but only 59 appear in the fastest solvers table. Don't think its a cache problems since its been showing so for a day and I have also tried force reload.
Image

User avatar
hk
Administrator
Posts: 10422
Joined: Sun Mar 26, 2006 9:34 am
Location: Haren, Netherlands

Re: Errors/Warnings/Bugs

Post by hk » Sat Dec 08, 2018 8:58 pm

As you can see Fastest Solvers Table and overview are in sync now.
The solve count is cached on the site.
It's not updated until someone solves the problem or an admin views who solved this problem. Even then the overview page is cached so the updated count is only showed when the overview page is refreshed.
When for some reason the solve count is decreased and no one solves the problem (or an admin views who solved the specific problem) this decrepancy remains.
Some reasons for the decrease of the solve count can be:
someone deletes his account or someome resets his progress or someone makes his account private or an admin action on some account.
Anyhow this discrepancies are not an error or a bug but inherent to the workings of the site.
Image

LilStalker
Posts: 54
Joined: Thu Nov 03, 2016 4:32 pm

Re: Errors/Warnings/Bugs

Post by LilStalker » Sun Dec 09, 2018 7:25 am

Thank you for the explanation :)
Image

300iq
Posts: 1
Joined: Thu Jan 03, 2019 3:34 pm

Re: Errors/Warnings/Bugs

Post by 300iq » Thu Jan 03, 2019 3:36 pm

I thought i was top100 at 649 solving.. Like there was written that i am 96-th user to solve.. But there are no my account at top 100 :(

User avatar
hk
Administrator
Posts: 10422
Joined: Sun Mar 26, 2006 9:34 am
Location: Haren, Netherlands

Re: Errors/Warnings/Bugs

Post by hk » Thu Jan 03, 2019 9:15 pm

Look up your account. Perhaps it has been set to unlisted.
Image

marijan
Posts: 3
Joined: Fri Feb 22, 2013 6:58 pm

Sorry, but the requested table would contain too many members to be displayed

Post by marijan » Sat Jan 12, 2019 11:53 am

"Sorry, but the requested table would contain too many members to be displayed"

message is received instead of displaying statistics for Python language at

"https://projecteuler.net/language=Python"

LilStalker
Posts: 54
Joined: Thu Nov 03, 2016 4:32 pm

Re: Errors/Warnings/Bugs

Post by LilStalker » Sat Jan 12, 2019 4:31 pm

I believe this is working as intended.
Image

marijan
Posts: 3
Joined: Fri Feb 22, 2013 6:58 pm

Re: Errors/Warnings/Bugs

Post by marijan » Tue Jan 15, 2019 8:21 pm

I think it's not expected behavior. Statistics for other languages are displaayed as expected. I suppose it has somethning with Total number of members, since Python is the only one over 50000.
And it I tried it on different computers/OSes/browsers,
from different locations.

User avatar
hk
Administrator
Posts: 10422
Joined: Sun Mar 26, 2006 9:34 am
Location: Haren, Netherlands

Re: Errors/Warnings/Bugs

Post by hk » Tue Jan 15, 2019 8:27 pm

It's the way it is intended.
If you go to the main statistics page and switch to "view data for active members only" you can view the active Python members.
Image

marijan
Posts: 3
Joined: Fri Feb 22, 2013 6:58 pm

Re: Errors/Warnings/Bugs

Post by marijan » Tue Jan 15, 2019 9:15 pm

Well, it is intended indeed. Thanks for aneswers.

Ebrahim2000
Posts: 3
Joined: Fri Nov 23, 2018 5:48 pm

Re: Errors/Warnings/Bugs

Post by Ebrahim2000 » Tue Apr 16, 2019 7:11 pm

I just refreshed the site and it switched my account to another guy's account? refreshing again doesn't change it again.
E: Closing and opening the browser gets me into another account.

User avatar
euler
Administrator
Posts: 3069
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler » Thu Apr 18, 2019 3:44 pm

Sorry, but I've just noticed this. Could you send me a PM with your account name and the name of the different account you were seeing? It would be helpful if you could outline as many details as possible in the PM: Were you in a public place? Did you recognise the name of the account? Did you have full access to that account? Did it resolve? Did it happen again? Thanks.
Image
impudens simia et macrologus profundus fabulae

jpeg13
Posts: 9
Joined: Fri Aug 18, 2017 7:51 pm

Re: Errors/Warnings/Bugs

Post by jpeg13 » Fri May 03, 2019 3:47 pm

Hi,
I've solved problem 667 this morning, at 7:11 am CEST according to the problem page on my account. Shortly after having got the green check mark, I could see my account name at position 48 in the problem's fastest solvers list. Later on (after cache update I presume) I could see my account name in the Eulerian list with 2 points, and accordingly my position in the fastest solver list had moved to 49. In the mean time my account name has disappeared both from the fastest solver list and from the Eulerian list! I still see the problem as solved on the problem page or on the recent problems list. My solution time (5 days, 14 hours and 11 minutes if I calculate correctly) would actually come in position 49 of the fastest solvers list I'm currently seeing.
I've also noticed at least 2 times recently that the solvers count for this problem on the recent problem list decreased.
Is this an issue or do I need to clear some sort of cache?
Image

jpeg13
Posts: 9
Joined: Fri Aug 18, 2017 7:51 pm

Re: Errors/Warnings/Bugs

Post by jpeg13 » Fri May 03, 2019 6:51 pm

Update to my above post: apparently my account have been permanently de-listed and I also see no option to revert that on my account page. :shock: No idea why it is so, at least I never intended to de-list my account and I'm not aware of any behaviour from my side which would deserve permanent de-listing... May I ask for more information?
Image

User avatar
hk
Administrator
Posts: 10422
Joined: Sun Mar 26, 2006 9:34 am
Location: Haren, Netherlands

Re: Errors/Warnings/Bugs

Post by hk » Fri May 03, 2019 7:21 pm

Apologies. Everything should be allright now.
Image

jpeg13
Posts: 9
Joined: Fri Aug 18, 2017 7:51 pm

Re: Errors/Warnings/Bugs

Post by jpeg13 » Sat May 04, 2019 12:22 pm

Thanks and no worries, it was a good lesson of how much I appreciate PE in the mean time :wink: Everything looks as it used to be now after the various statistics updates.
Image

ranmink
Posts: 2
Joined: Mon May 06, 2019 12:26 pm

Re: Errors/Warnings/Bugs

Post by ranmink » Mon May 06, 2019 12:37 pm

I get a bug when I try to navigate to page 2 of the Palau statistics. It redirects me to the main countries page, with the header stating to go the forum if the problem persists. It also indicates that there should be a page 2, since we have more members in that country than fit the first page.

So to reiterate:
https://projecteuler.net/country=Palau;page=2
redirects to
https://projecteuler.net/countries

This happens on multiple computers and accounts.
Page 1 displays 100/121 members, which suggests a page 2 should exist

User avatar
Jochen_P
Posts: 53
Joined: Mon Oct 05, 2009 9:47 am
Location: Stuttgart, Germany

Re: Errors/Warnings/Bugs

Post by Jochen_P » Mon May 06, 2019 12:51 pm

Image

User avatar
euler
Administrator
Posts: 3069
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler » Mon May 06, 2019 1:11 pm

Sometimes it happens that the caches get corrupted during generation. It will resolve itself in 12 hours (when the old cache expires) and normally it is rare, but two at the same time suggests something is going on. I've fixed those two mentioned, but I'll keep an eye on it.
Image
impudens simia et macrologus profundus fabulae

imstupid

Re: Errors/Warnings/Bugs

Post by imstupid » Thu May 09, 2019 11:34 pm

Hi,

I haven't logged into my account for a long while (10 years, I believe) after graduating from high school. I participated in OI/ACM/Topcoder/Codeforces at that time. The day before yesterday one of my current fellow students asked me about how to solve Problem 667 and I logged back, solved it in a day. After I submitted my solution -- which turned to be correct -- I got a message saying "THIS ACCOUNT HAS BEEN PERMANENTLY DE-LISTED".
I understand this is because I haven't touched my account for a long, long time. I was wondering how to have my account back?
Thanks!

Post Reply