Errors/Warnings/Bugs

Announcements, comments, ideas, feedback, and "How do I... ?" questions
forarslys
Posts: 10
Joined: Thu Jul 30, 2020 9:36 pm

Re: Errors/Warnings/Bugs

Post by forarslys »

Another tiny image issue.
The problem 155 uses an image for 'μ' in the statement, resulting in an unnatural gap in the dark mode.
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thank you for highlighting that. I've changed it to TeX.
Image
impudens simia et macrologus profundus fabulae
ecnerwal
Posts: 2
Joined: Tue Dec 12, 2017 10:42 pm

Re: Errors/Warnings/Bugs

Post by ecnerwal »

The solve history API/download seems to give problem numbers that are too high by 1, i.e. right now, the numbers it returns are all in the range [002, 745].
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thank you. That should be fixed now.
Image
impudens simia et macrologus profundus fabulae
ricbit_pandemic
Posts: 1
Joined: Sun Jan 31, 2021 1:56 pm

Re: Errors/Warnings/Bugs

Post by ricbit_pandemic »

Hi Mr. Euler,

Today I was in the first hundred to solve a problem, for first time, with problem 745. However I didn't get the award for this. Is it a bug, or does it take some time to be updated?
tb65536
Posts: 1
Joined: Sun Jan 31, 2021 5:02 pm

Re: Errors/Warnings/Bugs

Post by tb65536 »

My "Fastest Solvers" table for problem 740 (https://projecteuler.net/fastest=740) has many duplicate entries:
- endagorion appears twice
- Golovanov399 appears twice
- msinghal appears four times
- Zach-Lurf appears four times
- x22 appears three times
- brob26 appears twice
- aleksey appears three times
- BerkeleyMath appears five times
- radeye appears three times

Is this just on my end, or is this more serious?
lionel.m
Posts: 1
Joined: Mon Dec 10, 2018 1:39 pm

Re: Errors/Warnings/Bugs

Post by lionel.m »

I just noticed the same bug on Fastest Solvers pages for problems 743, 742 , 741, 739, ...
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Thank you for reporting this. I've just made a change that I am hoping is going to fix the problem. The tables have all been re-cached, but if you notice it happening again, then please let me know.
Image
impudens simia et macrologus profundus fabulae
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

ricbit_pandemic wrote: Sun Jan 31, 2021 1:58 pm Today I was in the first hundred to solve a problem, for first time, with problem 745. However I didn't get the award for this. Is it a bug, or does it take some time to be updated?
Yes, sadly it is a bug. I'm currently fixing it for the next problems. But as this is one of the permanent awards (you can't lose it), the down side is that you cannot earn it retrospectively. However, panic not! I've manually given you the award for #745.

If anyone else has missed out on the "One in a Hundred" award this week (or "Chart Topper") due to the bug, let me know and I can manually award it to you - after checking you're not pulling a fast one, of course! :wink:
Image
impudens simia et macrologus profundus fabulae
cup_of_tea
Posts: 2
Joined: Sun Jan 31, 2021 9:29 pm

Re: Errors/Warnings/Bugs

Post by cup_of_tea »

Hi,

I'm having a bug when submitting the solution for the problem 69.
It displays that I have the correct answer (with all the usual stats informations, and giving me the "lvl 3"), but it doesn't update on my profile.

The problem is still in the "unsolved" problems, I can't access to the forum thread, and it doesn't show in my progress neither.

The behaviour is identical if I try to submit again.

Thanks in advance!
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

My bad! :oops:

It should be working again. Please see here:
https://projecteuler.chat/viewtopic.php ... 693#p59693
Image
impudens simia et macrologus profundus fabulae
cup_of_tea
Posts: 2
Joined: Sun Jan 31, 2021 9:29 pm

Re: Errors/Warnings/Bugs

Post by cup_of_tea »

Thanks a lot! And no problem ;)

Edit: Yes it worked <3
v6ph1
Posts: 131
Joined: Mon Aug 25, 2014 7:14 pm

Re: Errors/Warnings/Bugs

Post by v6ph1 »

I solved the latest problem 749.
After I typed in my solution, they showed me, I was 70th.
But I can not enter the solution thread (no access) and neither the problem description nor my progress showed my that I've solved the problem.

EDIT: The last entry in the fastest solver table is 40 minutes ago: ~7pm (GMT).

I tried it after a few minutes again, but this doesn't resolved the problem.

best regards
Last edited by v6ph1 on Sat Feb 27, 2021 7:43 pm, edited 1 time in total.
Image
User avatar
neverforget
Posts: 39
Joined: Sat Sep 16, 2006 10:10 pm

Re: Errors/Warnings/Bugs

Post by neverforget »

I'm also getting same issue on 749. I get the green check mark along with usual correct answer message, but no update to progress or fastest solvers.
Image
nett_hier
Posts: 1
Joined: Sat Feb 27, 2021 8:19 pm

Re: Errors/Warnings/Bugs

Post by nett_hier »

Getting the same issue with problems 51-54...
Seems to affect everything right now.
mutatedi
Posts: 1
Joined: Sat Feb 27, 2021 8:29 pm

Re: Errors/Warnings/Bugs

Post by mutatedi »

Hi,

I'm having a bug when submitting the solution for the problem 57.
It displays that I have the correct answer (with all the usual stats informations), but it doesn't update on my profile.

The problem is still in the "unsolved" problems, I can't access to the forum thread and it doesn't show in my progress neither.

The behaviour is identical if I try to submit again.

Thanks in advance!
Attachments
Capture d’écran 2021-02-27 à 21.39.39.png
Capture d’écran 2021-02-27 à 21.39.39.png (128.38 KiB) Viewed 958 times
sukunrt
Posts: 1
Joined: Sat Feb 27, 2021 8:57 pm

Re: Errors/Warnings/Bugs

Post by sukunrt »

I am facing the same issue. Tried problems 178 and 267
Attachments
Screenshot 2021-02-28 at 12.55.50 AM.png
Screenshot 2021-02-28 at 12.55.50 AM.png (581.63 KiB) Viewed 948 times
User avatar
euler
Administrator
Posts: 3634
Joined: Sun Mar 05, 2006 4:49 pm
Location: Cheshire, England
Contact:

Re: Errors/Warnings/Bugs

Post by euler »

Sorry about that. It should now be fixed if you submit your answer again.
Image
impudens simia et macrologus profundus fabulae
v6ph1
Posts: 131
Joined: Mon Aug 25, 2014 7:14 pm

Re: Errors/Warnings/Bugs

Post by v6ph1 »

thanks - works for me now.
Image
amonakov
Posts: 3
Joined: Sun Mar 07, 2021 7:45 am

Re: Errors/Warnings/Bugs

Post by amonakov »

euler wrote: Sun Jan 31, 2021 6:36 pm If anyone else has missed out on the "One in a Hundred" award this week (or "Chart Topper") due to the bug, let me know and I can manually award it to you - after checking you're not pulling a fast one, of course! :wink:
Yesterday I was in first ten to solve problem 750, but only got "On the Ball" without "Chart Topper" and "One in a Hundred".
Post Reply